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1 Introduction

License: Copyright (C) 2018, Daniel H. Huson, with some code written by other authors, as
mentioned in the corresponding source files.

This program is free software: you can redistribute it and/or modify it under the terms of the
GNU General Public License as published by the Free Software Foundation, either version 3 of the
License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program. If
not, see http://www.gnu.org/licenses.

Type-setting conventions: In this manual we use e.g. Edit→Find to indicate the Find menu
item in the Edit menu.

How to cite: If you publish results obtained in part by using Dendroscope , then we require that
you acknowledge this by citing the program as follows:

• Daniel H. Huson and Celine Scornavacca. Dendroscope 3: An interactive tool for rooted phy-
logenetic trees and networks, Systematic Biology (2012), http://sysbio.oxfordjournals.
org/cgi/content/abstract/sys062?ijkey=ZCxPRbYt74aQJhR&keytype=ref, software
freely available from www.dendroscope.org.

This manual is based on the user manual for Dendroscope 1, which was written by Daniel H. Huson,
Daniel C. Richter, Christian Rausch and Regula Rupp.

The source files for Dendroscope can be found here: http://danielhuson.github.io/

dendroscope3

2 Program Overview

Dendroscope is a platform-independent software written in Java that enables conveniently to browse
phylogenetic trees and networks with up to hundreds of thousands of taxa. Here is an overview of
its features:
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• There are 8 different tree views available, e.g. phylogram, cladogram or radial views.

• Its novel navigational features facilitate the analysis of large trees.

• It provides several tree manipulating functions like rerooting, subtree rotating, tree flipping
and formatting features like renaming, coloring or resizing edges, nodes and labels.

• A comprehensive set of export formats for the generation of images is available.

• User formatted trees can be saved as a NeXML project file or as .nexus, or Newick tree files.

• Tree structures (single or multiple) can be loaded from .tre (Newick format) or .nexus files
or entered manually.

• Rooted phylogenetic networks can be entered and visualized using the Extended Newick
format [4].

• The program permits the computation of consensus trees from a set of input trees.

• The program also permits the computation of rooted phylogenetic networks (among others
cluster networks [11], galled networks [12], minimum networks [22] and hybridization networks
[1, 15]) from a set of input trees.

• It provides several tree manipulating functions like rerooting, subtree rotating, tree flipping
and formatting features like renaming, coloring or resizing edges, nodes and labels.

3 Obtaining and Installing the Program

Dendroscope is written in Java and requires a Java runtime environment version 1.7 or later, freely
available from www.java.org.

Dendroscope is installed using an installer program that is freely available from
www.dendroscope.org. There are three different installers, targeting different operating systems:

• Dendroscope windows 3.8.10.exe provides an installer for Windows.

• Dendroscope macos 3.8.10.dmg provides an installer for MacOS.

• Dendroscope unix 3.8.10.sh provides a shell installer for Linux and Unix.

Alternatively Dendroscope will be available as Java Webstart application from
http://ab.inf.uni-tuebingen.de/data/software/dendroscope/webstart/. If you need information
concerning Java Webstart, go to http://java.sun.com/products/javawebstart/.

4 Getting Started

This section describes how to get started and to do the first steps of analyses using Dendroscope .

First, download an installer for the program from www.dendroscope.org, see Section 3 for details.
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Start the program and load any .tre, .nexus, .nexml or .dendro project file via File→Open .
Alternatively, if the file was recently opened by the program, then it may be contained in the
File→Open Recent submenu.
At startup, the tree will be scaled to fit to the window size.

Draw the tree differently by choosing one of the 8 provided views e.g. Layout→Draw

Rectangular Phylogram , Layout→Draw Rectangular Cladogram , Layout→Draw Slanted

Cladogram , Layout→Draw Circular Phylogram , Layout→Draw Circular Cladogram ,
Layout→Draw Inner Circular Cladogram , Layout→Draw Radial Phylogram , Layout→Draw

Radial Cladogram . Try out the magnifier functions by clicking on View→Use Magnifier .
Change any label font, size, color or edge/node size/width by opening the Format Panel via
Edit→Format .

If you want to print the current image choose File→Print . In case you need a quality image of
the tree, simply export it to several file formats via File→Export Image .

Finally, if you want to save the tree(s) and the formatting click File→Save As generating a
.nexml project file. You can also export the tree(s) by clicking File→Export . Choose one of the
export formats (newick or nexus).

Note that only by saving a formatted tree as a .nexml project file you can save the formatting with
the tree.

5 Main Window

The Main window is used to display the taxonomy and to control the program via the main
menus.

We now discuss all menus of the Main window.

5.1 File Menu

The File menu contains the following file-related items:

• The File→New item opens a new document. Any selected trees are put in it.

• The File→Open item provides an Open File dialog to open one or more files containing
input data. The supported formats are .nexml, .dendro, .tre, .nexus (see Section 8). Note
that the standard open dialog does not allow one to open more than one file under MacOS
X. As a work-around, press the shift-key when selecting the File→Open menu item so as to
obtain an alternative file open dialog that allows one to select more than one file for opening.
When opening a file, Dendroscope inspects the first input tree to determine whether all its
internal nodes are labeled by numbers. If this is the case, then the user is presented with a
dialog to determine whether to interpret the numbers as node labels, as edge support values
(e.g. bootstrap values) or whether to delete them.

• The File→Open Recent can be used to re-open a recently opened file.

• The File→Add From File item adds trees or networks from a file to the current document.
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• The File→Enter Trees or Networks item enters trees in Newick or networks in extended
Newick format.

• The File→Save item saves the current document in NeXML format.

• The File→Save As item saves the current document under a new name.

• The File→Export item opens the Choose output format dialog which is used to
export the current trees or networks in a number of file formats, see Section 8.

• The File→Duplicate item duplicates this document.

• The File→Export Image item opens the Export Image dialog which is used to save the
current network in a number of different graphics formats, see Section 8.6.

• The File→Page Setup item setups the page for printing.

• The File→Print item prints the network.

• The File→Close item closes the current window. In case only one window is opened,
the application exits.

• The File→Quit item quits the program (Windows and Linux only).

5.2 Edit Menu

The Edit menu contains the usual edit-related items:

• The Edit→Copy item is used to copy the current tree or network or all selected trees or
networks.

• The Edit→Copy Image item is used to copy the current tree or network or all selected
trees or networks as an image that can be pasted into another program, e.g. PowerPoint.

• The Edit→Paste item is used to paste the copied trees or networks to a new tab.

• The Edit→Find item opens the Find tool bar which can be used to search for taxa.

• The Edit→Find Again item finds the next occurrence of a search string.

• The Edit→Replace item opens the Replace tool bar which can be used to replace taxon
names.

• The Edit→Reroot item reroots the tree or the network at the specified nodes or edge.
If more than node is selected, all selected taxon labels are intepreted as outgroup taxa and
the program determines the “tightest” rooting so that the outgroup appear together below
the root. If several nodes share the same label, all these nodes are considered to determine
the “tightest” rooting.

• The Edit→Swap Subtrees item swaps the order of subtrees (or subnetworks) below the
specified node (or nodes).
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• The Edit→Rotate Subtrees item rotates the order of the subtrees (or subnetworks)
below the specified node(s).

• The Edit→Reorder Subtrees item opens the Reorder subtrees dialog that allows
one to specific any type of reordering of the children of the specified node using “drag and
drop’.

• The Edit→Delete Taxa item removes the selected taxa in the selected trees or networks

• The Edit→Unlock Edge Lengths item is used to “unlock edge lengths” so that the user
is allowed to reshape trees or networks by dragging nodes or internal edge points.

• The Edit→Format item opens a Format Panel which provides several possibilities to
change color, fonts, node and edge shapes and the positioning of the labels of the tree.

5.3 Select Menu

The Select menu contains items for selecting panels and different sets of substructures of trees
or networks.

• The Select→Advanced Selection submenu contains a number of advanced selection
menu items that are probably not of general interest.

• The Select→All Panels item selects all panels.

• The Select→No Panels item deselects all panels.

• The Select→Invert Panels item inverts the selection of all panels.

• The Select→Select All item is used to select all nodes and edges.

• The Select→Select Nodes item is used to select all nodes.

• The Select→Select Edges item is used to select all edges.

• The Select→From Previous Window item is used to apply the selection of the previous
window to the active window.

• The Select→Deselect All item is used to deselect all nodes and edges that are currently
selected.

• The Select→Deselect Nodes item is used to deselect all nodes that are currently
selected.

• The Select→Deselect Edges item is used to deselect all edges that are currently selected.

• The Select→Select Labeled Nodes item is used to select all labeled nodes.

• The Select→Select Leaves item is used to select all leaves.

• The Select→Select Root item is used to select the root node of the tree.
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• The Select→Select Non-Terminal item is used to select all non-terminal nodes and
edges.

• The Select→Select Special item is used to select all edges leading to reticulation
nodes in networks.

• The Select→Invert Selection item is used to invert the current selection.

• The Select→Scroll to Selection item is used to scroll to the current selection.

• The Select→List Selected Taxa item is used to list all selected taxa.

The advanced selection submenu contains the following items:

• The Advanced Selection→Select Subnetwork item is used to select the subtree or subnetwork
below a selected inner node or edge..

• The Advanced Selection→Select Induced Network item is used to select a subtree or subnet-
work induced by the set of currently selected nodes.

• The Advanced Selection→Select LSA Induced Network item is used to select the subtree or
subnetwork rooted at the LSA of the selected nodes.

• The Advanced Selection→Select Spanned Edges item is used to select all edges spanned by
the set of currently selected nodes.

5.4 Options Menu

The Options menu contains items for collapsing nodes and extracting subtrees.

• The Options→Advanced Options submenu contains some advanced options that are
probably not of general interest.

• The Options→Internal Node Labels Interpreted As Edge Labels item should be
used when internal tree nodes are labeled by support values (such as bootstrap values) and
one wants to reroot one or more trees. Selecting this option will ensure that values will be
correctly transformed when rerooting.

• The Options→Collapse item enables to collapse subtrees or subnetworks below the
specified nodes. The former subtrees or subnetworks are replaced by rectangles.

• The Options→Uncollapse item is used to uncollapse (expand) the selected, collapsed
subtrees or subnetworks .

• The Options→Uncollapse Subtree item is used to uncollapse (expand) all collapsed
subtrees or subnetworks below the specified nodes.

• The Options→Collapse Complement item is used to collapse all subtrees or subnetworks
except the currently selected part of the tree or subnetwork

• The Options→Collapse at Level item is used to collapse all subtrees or subnetworks
at the specified level from the root.
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• The Options→Load Taxon Images item is used to specify a directory containing image
files. Dendroscope tries to match taxon names to the names of images files and for each match
found, Dendroscope shows the image near the node representing the given taxon (recognized
formats: GIF, JPG, JPEG, BMP and PNG).

• The Options→Set Image Size item is used to set the size of the image for the currently
selected nodes.

• The Options→Image Position submenu is used to determine the relative positions of
images in relative to the corresponding nodes (North, South, East, West, Radial).

• The Options→Next Tree item moves to the next tree.

• The Options→Previous Tree item moves to the previous tree.

• The Options→Go to Tree item goes to a specific tree.

• The Options→Set Tree Name item sets the name of a tree or network.

The advanced options submenu contains the following items:

• The Advanced Options→Extract Subnetwork item is used to extract a subtree or subnetwork
below a node or edge.

• The Advanced Options→Extract Induced Network item is used to extract a subtree or subnet-
work induced by the selected nodes to a new file.

• The Advanced Options→Extract LSA Induced Network item is used to extract a subtree or
subnetwork rooted at the LSA of the selected nodes to a new file.

• The Advanced Options→Extract Induced Restriction item is used to extract the restriction
induced by the selected nodes to a new file.

5.5 Algorithms Menu

The Algorithms menu contains items for computing networks from trees and for comparing
trees or networks.

• The Algorithms→Advanced Algorithms submenu contains additional advanced algo-
rithms that are probably not of general interest.

• The Algorithms→Strict Consensus item is used to compute the strict consensus of
a set of trees.

• The Algorithms→Loose Consensus item is used to compute the loose consensus of a
set of trees.

• The Algorithms→Majority Consensus item is used to compute the majority consensus
of a set of trees.

• The Algorithms→LSA Consensus item is used to compute the LSA consensus of a
set of trees [13].
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• The Algorithms→Primodial Consensus item is used to compute the primodial con-
sensus of a set of trees [20].

• The Algorithms→Network Consensus item is used to compute a rooted network
consensus of a set of trees.

If the input set contains more than two trees, then the user can set a threshold that determines
the percentage of input trees that a cluster must be contained in to make it into the output
rooted network. The user can also decide whether the program should come a cluster
network [11] that shows the clusters in a hardwired representation , a galled network
[12] that represents the clusters in a topologically restricted softwired representation , or a
minimum network that attempts to represent the clusters in a network of minimum level
, as described in [22].

• The Algorithms→Network for Multi-Labeled Tree menu item is used to compute
a rooted phylogenetic network for a multi-labeled tree such that the network contains each
label (or taxon) exactly once. There are three methods available here: the cluster-based
method extracts all the clusters in the tree and constructs a cluster network. The exact
method computes the nested label for the root node of the tree and then constructs the
corresponding network for that label [7]. The level-k-based method extracts all clusters
and then seeks to compute a level-k network of minimum level k for the clusters.

• The Algorithms→Hybridization Network item computes all minimum hybridization
networks for two rooted phylogenetic trees, not necessarily binary, on overlapping taxon sets
using the Autumn algorithm [15].

• The Algorithms→Hybridization Network (Binary Trees) item computes all minimum
hybridization networks for two bifurcating trees on the same taxon set [1].

• The Algorithms→Reroot By Hybridization Number item determines a rooting that
minimizes the hybridization number, given two rooted phylogenetic trees, not necessarily
binary, on overlapping taxon sets, using the Autumn algorithm [15].
item The Algorithms→Tanglegram→i tem is used to compute a tanglegram for two
trees or networks using a NeighborNet-based heuristic [19].

Note that Dendroscope does not require that the trees all contain exactly the same set of taxa to
be able to compute a consensus (unlike most other programs), as it uses the Z-closure method to
merge partial data [14].

The advanced algorithms submenu contains the following items:

• the Advanced Algorithms→Hybridization Number item is used to compute the hybridization
number for two rooted trees using the Autumn algorithm [15]. Trees need not be binary and need not
have identical taxon sets.

• the Advanced Algorithms→Hybridization Number (Binary Trees) item is used to compute
the hybridization number for two selected rooted binary trees on the same taxon set [1].

• the Advanced Algorithms→rSPR Distance (Binary Trees) item is used to compute the rSPR
distance for two selected rooted binary trees on the same taxon set [23].
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• the Advanced Algorithms→DTL Reconciliation item is used to calculate the DTL reconciliation
between two binary trees [5].

• the Advanced Algorithms→Hardwired Cluster Distance item is used to calculate the hardwired
cluster distance between two trees or networks [13].

• the Advanced Algorithms→Softwired Cluster Distance item is used to calculate the softwired
cluster distance between two trees or networks [13].

• the Advanced Algorithms→Displayed Trees Distance item is used to calculate the displayed
trees distance between two trees or networks [13].

• the Advanced Algorithms→Tripartition Distance item is used to calculate the tripartition
distance between two trees or networks [16].

• the Advanced Algorithms→Nested Labels Distance item is used to calculate the nested labels
distance between two trees or networks [3, 17].

• the Advanced Algorithms→Path Multiplicity Distance item is used to calculate the path
multiplicity distance between two trees or networks [2].

• The Advanced Algorithms→Simplistic item computes a phylogenetic networks using the sim-
plistic algorithm [21].

5.6 Layout Menu

The Layout menu contains items for different tree and network views [9].

• The Layout→Draw Rectangular Phylogram item is used to draw trees or networks as
rectangular phylograms.

• The Layout→Draw Rectangular Cladogram item is used to draw trees or networks as
rectangular cladograms.

• The Layout→Draw Slanted Cladogram item is used to draw trees or networks as slanted
cladograms.

• The Layout→Draw Circular Phylogram item is used to drawtrees or networks as circular
phylograms.

• The Layout→Draw Circular Cladogram item is used to draw as circular cladograms.

• The Layout→Draw Inner Circular Cladogram item is used to draw trees or networks
as circular cladograms with leaves on the inside.

• The Layout→Draw Radial Phylogram item is used to draw trees or networks as radial
phylograms.

• The Layout→Draw Radial Cladogram item is used to draw trees or networks as radial
cladograms.

• The Layout→Ladderize Left item is used to order trees or networks so that the largest
clades appear leftmost (uppermost in the view).
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• The Layout→Ladderize Right item is used to order trees or networks so that the largest
clades appear rightmost (lowermost in the view).

• The Layout→Ladderize Random item is used to order the clades randomly.

• The Layout→Network Layout item is used to choose the way the network embedding
is computed. There are four methods available here. With No Optimization , we do
not attempt to optimize the embedding of networks. The 2008 Algorithm optimizes
embedding of networks using the algorithm described in (Kloepper and Huson 2008). The
2009 Algorithm optimizes embedding of networks using the algorithm described in (Huson
2009). The 2010 Algorithm optimizes embedding of networks using a new algorithm
developed by Huson and Scornavacca in 2010.

• The Layout→Align Taxa item: Attempts to align taxa in all selected trees or networks
using an algorithm described in [19].

• The Layout→Connect Taxa item: Connect all taxa of the same name in different trees
or networks.

• The Layout→Disconnect All item: Disconnect all nodes in different trees or networks.

5.7 View Menu

The Views menu contains items for setting the grid, scaling trees or networks, using the magnifier
and showing/hiding labels.

• The View→Set Grid item is used to set the tree or network grid dimensions.

• The View→Less Panels item is used to lessen the number of panels in the grid.

• The View→More Panels item is used to increase the number of panels in the grid.

• The View→Show Scroll Bars item is used to show or hide scroll bars.

• The View→Show Borders item is used to show or hide borders.

• The View→Show Scale Bar item is used to show or hide scale bar.

• The View→Zoom to Fit item is used to scale the tree or network to fit the window.

• The View→Fully Contract item is used to contract the tree or network.

• The View→Fully Expand item is used to expand the whole tree or network.

• The View→Use Magnifier item is used to turn the magnifier functionality on and off.

• The View→Magnify All Mode item modifiers the magnification process so that the whole
tree gets mapped into the magnifier.

• The View→Show Node Labels item is used to make all node labels visible or invisible.
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• The View→Show Edge Labels item is used to make edge labels visible or invisible.

• The View→Label Edges By Weights item uses the edge weights as edge labels.

• The View→Sparse Labels item instructs the program to show only a subset of the taxon
labels, thus avoiding overlapping labels.

• The View→Radial Labels item instructs the program to rotate leaf labels to match the
orientation of the edges that lead to them.

• The View→Reposition Labels item sets all the labels to their original position.

5.8 Window Menu

The Window menu contains a number of window-related commands as well as a list of all currently
open windows.

• The Window→About item opens a splash screen showing the program version. In MacOS,
this can be found under Dendroscope→About .

• The Window→How to Cite item shows the citation info for this software which is:
(1) Daniel H Huson, Daniel C Richter, Christian Rausch, Tobias Dezulian, Markus Franz
and Regula Rupp. Dendroscope: An interactive viewer for large phylogenetic trees . BMC
Bioinformatics 8:460, 2007. (2) Daniel H Huson and Celine Scornavacca. Dendroscope 3: a
tool for drawing, modifying and computing rooted phylogenetic networks. In preparation.

• The Window→Website item is used to go to the program website.

• The Window→Set Window Size item is used to set the size of the Main window.

• The Window→Command-line Syntax item lists all commands supported by the program.

• The Window→Command Input item opens a window that can be used to enter a command
(see command). tree or network manually in Newick Format.

• The Window→Message Window item is used to open the Message window.

• If several program windows are opened, they are listed at the end of the window menu.

5.9 Toolbar

For easier access of frequently used functions, a Toolbar is provided. The button images are
self-explicative and a description appears when passing on the buttons with the mouse.
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5.10 Context Menus

A right mouse click when the index finger of the hand icon is positioned on a node opens a context
menu which allows to edit the node label, open the Format Panel, show or hide node labels, copy
the node label, select the subtree starting from this node, and swap the subtree starting from this
node.

A right mouse click when the index finger of the hand icon is positioned on an edge opens a context
menu which allows to edit the edge label, open the Format Panel, show or hide edge labels, and
copy the edge label.

A right mouse click beside the tree opens a context menu which allows to select or deselect all
edges, nodes, and labels, to scale the tree or network to fit the window or finally to show or hide
scroll bars and borders.

5.11 Status Line

The Status Line at the bottom of the program window shows the index of the current tree,
the total number of trees, the number of nodes and edges and the available space of the reserved
memory.

6 Additional Windows

6.1 Format Panel

The Format Panel can be opened via Edit→Format or by a right mouse click after selecting
elements of the tree like edges, nodes or labels. You can format them as follows:

• Edges can have their edge width and edge width set.

• Edges can be assigned three types of shapes: straight edges, curved edges and angular edges,
the effect of which depends on the current view.

• Nodes can be assigned certain shapes: square nodes, circle nodes or none. Square and circle
node shapes can have their node size and node color set.

• If a selected node or edge has a label, then you can choose its font family, font style or font
size.

• Labels can be switched on and off, and can be rotated to the left or right.

Configuration changes are applied immediately. The Options→Save Font As Default menu
item can be used to set the default font, style and size used by the program.
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6.2 Find and Replace Toolbars

The Find toolbar can be opened or closed using the Edit→Find menu item. Its purpose is
to search labels in the displayed trees or networks. Enter a query specifying the text to find in the
top text region. Use the following check boxes to configure the search:

• If the Case sensitive item is selected, then the case of letters is distinguished in com-
parisons.

• If the Whole words only item is selected, then only taxa or labels matching the complete
query string will be returned.

• If the Regular Expression item is selected, the query is interpreted as a Java regular
expression (see example further down).

The scope of the search can be Global or Selection. If a searched label is ”hidden” inside a
bounding box (black opaque area of tree or network) or in a collapsed branch, it will be selected.

Press the Close, Find First, Find Next or Find All buttons to close the toolbar, or find the
first, or next occurrence of the query, respectively. Press Unselect All to unselect the highlighted
occurrences.

The Replace toolbar can be opened or closed using the Edit→Replace menu item. Its purpose
is to replace text in the displayed trees or networks. Enter a replacement text in the bottom text
region.

Press the Replace or Replace All buttons to replace the next or all occurrences of the query with
the text in the bottom text region, respectively.

Regular Expressions are powerful and flexible text-processing tools. They allow to specify
complex patterns of text that can be discovered in an input string.

Example 1:

Each of the following represent valid regular expressions, and all will successfully match the char-
acter sequence ”Escherichia”:

• Escherichia

• E.*

• [eE]scherichia

• [eE]sch[aeiou][a-z]ichi.*

Example 2:

To select the five taxa simultaneously, e.g. Human, Mouse, Dog, Cat and Rat, use the following
expression: Human|Mouse|Dog|cat|Rat and then press Find All .

For an extensive list of metacharacters and further explanations go to
http://java.sun.com/j2se/1.5.0/docs/api/java/util/regex/Pattern.html
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6.3 Message Window

The Message window is opened using the Window→Message Window item. The program writes
all internal messages to this window. The window contains the usual File and Edit menu items.

6.4 Export Image Dialog

The Export Image dialog is opened using the File→Export Image item. This dialog is used
to save an image of the current tree in a number of different formats, see Section 8.6.

The dialog permits to specify the file name and where to save the graphics file. The format is
chosen from a menu. There are two radio buttons Save whole image to save the whole image,
and Save visible region to save only the part of the image that is currently visible in the
main viewer.

6.5 About Window

The About Window is opened using the Window→About submenu ( Dendroscope→About in
MacOS). It reports the version of the program and its authors.

7 Additional Features

7.1 Using the Mouse to Select

Nodes, edges and labels can also be selected by clicking on them with the index finger of the hand
icon. If the left mouse click is press for 2 seconds or shift-clicking, an arrow appears: dragging the
mouse, it is possible to perform a rubber-band selection in which all objects contained within a
dragged rectangle are selected.

7.2 Magnifier Functionality

Dendroscope provides the user with a magnifier functionality that can be used to magnify
portions of the tree.

Selecting the View→Use Magnifier item adds a magnifier layer to the view.

• Magnifier band: For all rooted views (rectangular and slanted view) a magnifier band is
laid over the tree.

• Magnifier disk: For all unrooted views (radial and circular tree view) a circular magnifier
is laid over the tree.

The magnifier can be pulled to a desired position by grabbing its frame with the mouse. The
radius/width of the magnifier can be changed by dragging the rhomb at the magnifier’s border line.
The zoom factor of the magnifier can be changed via the [+,-] button.
Two magnifier modes are available depending on the current tree view.
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7.3 Navigating trees with keys and mouse wheel

Dendroscope allows one to browse and analyze trees. Navigating trees is facilitated by some
key bindings :

• Scrolling: Hold down the Shift button and use the mouse wheel to scroll top-down.
Hold down the Alt and Shift buttons and use the mouse wheel to scroll right-left.

• Zooming: Use the mouse wheel to zoom the tree. Zooming is centered on the current mouse
position. Press the shift key to zoom the graph in horizontal direction.

• Rotating: For circular and radial drawings, use the shift-key and left and right arrow keys to
rotate the tree.

Alternatively, use the arrow keys to scroll the tree or network, or additionally press the shift key
to zoom the graph in horizontal or vertical direction (zoom not available in this way for circular
and radial drawings). Use the alt and control keys for acceleration.

8 File Formats

Dendroscope uses the NeXML file format to store the data of the modified and/or formatted tree
or network. By convention, we use the suffix .nexml for NeXML files.

8.1 NeXML files

Dendroscope saves trees in a simple text-based format with the file extension .nexml. It contains
the tree in Newick notation and additional (machine-readable) information on the view, selections,
coloring etc. of the saved trees.

Trees can also be saved in Nexus and Newick format. However, when these formats are used, all
information on the layout of the trees, fonts, colors, line widths etc are lost.

8.2 Old Dendroscope files

For backward compatibility, this version of Dendroscope can still open .dendro files (see the old
version of this manual).

8.3 Nexus files

Dendroscope can read a Nexus file that contains a Nexus trees block and can export trees in this
format.

8.4 Newick files

Dendroscope can read Newick files and can export trees in this format.
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8.5 Extended Newick format and rooted phylogenetic networks

The Extended Newick format was designed as an extension of the Newick format to be able to
describe rooted phylogenetic networks in bracket notation. Unfortunately, there is not just one such
format, but a number of different ones. Dendroscope implements a version of the Extended-Newick
proposed by [4].

In Dendroscope, a rooted phylogenetic network is described as a single line of extended-Newick
format using brackets, as in the description of a rooted phylogenetic tree in the standard Newick
format, with additional labels placed at the end of node labels. These special labels are of the form
’#H1’, ’#H2’, etc. When parsing an extended-Newick string, all nodes whose labels end on ’#H1’
are identified with each other, all nodes that end on ’#H2’ are identified, etc.

For example, to describe a rooted phylogenetic network with three leaves labeled ’a’, ’b’ and ’c’, in
which ’b’ is to have a “reticulate” parent node that connects both above ’a’ and above ’c’, use the
following extended-Newick string:

((a,(b)#H1),(c,#H1));

Copy and paste this string into a Dendroscope window to see the corresponding network.

In Dendroscope, quite everything that can be done with a rooted tree can also be done with a
rooted phylogenetic network!

8.6 Graphics Formats

The following graphics formats are supported (how to open the Export Image dialog see 6.4):

• JPEG, “Joint Photographic Experts Group”.

• GIF, “Graphics Interchange Format”.

• SVG, “Scalable Vector Graphics”.

• PNG, “Portable Network Graphics”.

• BMP, “Bitmap”.

• PDF, “Portable Document Format”.

9 Using More Memory

The Dendroscope installer allows you to specify the amount of Dendroscope that the program can
use.

To run Dendroscope with more than 400 MB under MacOS X on an intel Mac, edit the file
〈installation-dir〉/Dendroscope/Dendroscope.app/Contents/Info.plist as follows: Find the lines
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<key>VMOptions</key>

<string>-server -Xmx400M</string><!-- I4J_INSERT_VMOPTIONS -->

and replace them by:

<key>VMOptions</key>

<string>-server -Xmx1000M </string><!--I4J_INSERT_VMOPTIONS -->

to run using 1 gigabyte, for example.

To run Dendroscope with more more than 400 Mb on a 64-bit unix/linux system, open the file
〈installation-dir〉/Dendroscope in a text editor. Find the current memory specification (e.g. -
Xmx400M) and replace it by -d64 -Xmx100M to run with 1 gigabyte of memory, say. Note that
the flag -d64 is necessary to specify 64-bit Java.

10 Commands

The program provides a command-interpreter to access all its functionalities. A command can be
entered either using the Window→Command Input item or by starting the program in command-line
mode and typing (or piping) commands to the program via the console.

The Command input window has a field for entering commands, a cancel button and two
different apply buttons. The Apply button applies the entered command to the current tree or
network, whereas the Apply to Every Tree in File button applies the entered command to all trees
and networks in the current file, each one separately. Use this button with care.

To start Dendroscope in command-line mode use the option -g. For example under MacOS X type

〈installation-dir〉/Dendroscope/Dendroscope.app/Contents/MacOS/JavaApplicationStub -g

in a terminal shell. To make things easier, in the command line version only one file is opened at
the time. When new trees or networks are computed, the file is emptied and filled with the newly
computed trees and networks. To apply a set of commands to all trees and networks in the current
file in the command line version, use the syntax:

apply-all-begin <command;> [<command>;..] apply-all-end;

Note that the Apply to All syntax should only be used for commands that change the trees (or
networks), e.g. for computing the consensus network or changing the drawer for all trees in the
file, and not for commands that change transient aspects of the visualization such as zoom factor,
edges/nodes selection etc. Also, it is pointless to use a command such as open file or add file in this
context.

Here is a summary of all available commands:

Opening and saving files:

open file=filename [init=command] ; Open the named file in the current window, if empty, otherwise in a new window,

and then optionally perform specified initial commands in new window

save [format=value] file=filename ; Save data to file in the specified format (possible formats: nexus newick nexml)

exportimage file=filename [format={PNG|GIF|JPG|SVG|PDF}] [replace=bool] [textasshapes=bool] [title=title] -
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Export a picture of the current tree

source file=filename ; Read commands (separated by semicolons) from the named file

new ; Open a new document. Any selected trees are put in it

Choosing tree and visualization:

go tree={first,next,prev,last,<num>} ; Go to the first, next, previous or last tree, or to a specific tree

set drawer=drawer-name ; Set the drawer used to draw the tree (Possible values: RectangularPhylogram RectangularCladogram SlantedCladogram

RadialPhylogram RadialCladogram CircularPhylogram CircularCladogram InnerCircularCladogram)

auxiliaryparameter change={increment|decrement};

Decrement|Increment the auxiliary parameter used by some of the drawers

Customizing the layout of a tree:

reroot ; Reroot current tree using currently selected set of nodes (outgroups), node or edge

ladderize=value ; Ladderize each displayed tree (possible values: left right random)

rotatesubtree ; Rotate all children of all selected nodes

swapsubtree ; Swap subtree below selected node(s)

reset labelpositions ; Reset all node label positions

center ; Center the trees

rotate angle=number ; Rotate the whole tree by the given angle (in radian)

set hflip={false|true} ; Flip the tree horizontally?

rotatelabels percent=<integer> ; Rotate the labels of selected nodes

Adding, creating and modifying trees:

add tree=newick-tree ; Add the specified trees or networks (in (extended) Newick format) to the list of trees

add file=filename ; Add trees or networks from a file to the current document

extract induced network ; Extract subtree or subnetwork induced by selected nodes

extract LSA induced network ; Extract subtree or subnetwork rooted at the LSA of the selected nodes

extract subnetwork ; Extract subtree or subnetwork below node or edge

remove taxa={selected|names} ; Remove all selected taxa, if taxa=selected, otherwise, remove named taxa

set unlockedgelengths={true|false} ; Allow user to reshape tree by dragging nodes or internal edge points

edit edgelabels ; Edit the selected edge labels

edit nodelabels ; Edit the selected node labels

align trees=selected-or-all ; Attempts to align taxa in all selected trees or networks

set name=<name> [treeId=<tree-number>]; Set the name of a tree or network

Algorithms:

compute mult2net method={HOLM|cluster|levelk} ;

Compute a network from a multi-labeled tree

compute consensus method={Strict|Majority|Loose|level-k-network threshold=<value> |cluster-network threshold=<value> |galled-network threshold=<value>|

Distortion1|LSAtree} ; Compute a consensus tree or network of a set of trees

compute tanglegram method={nnet} ; Compute a tanglegram for two trees or networks using the NeighborNet-based heuristic

compute triplets2network method=simplistic ;

Compute a network using the simplistic algorithm

compute hybridization-network method=Autumn;

Compute minimum hybridization networks for two rooted phylogenetic trees using the Autumn algorithm (Huson, in preparation)

compute hybridization-network method=ASCH2011 [showdialog={false|true}] [numberOfThreads=number];

Compute minimum hybridization networks for two bifurcating trees on the same taxon set using the

Albrecht, Scornavacca, Cenci, and Huson (2011) algorithm

compute hybridization-number method=Autumn;

Compute the hybridization number for rooted phylogenetic trees using the Autumn algorithm (Huson and Linz, 2016)

rerootby method=min-hybridization-number; Reroot to trees so as to minimize their hybridization number using the Autumn algorithm (Huson and Linz, 2016)

compute hybridization-number method=ASCH2011 [showdialog={false|true}] [numberOfThreads=number];

Compute the hybridization number for two rooted binary trees on the same taxon set

compute rspr-distance method=ASCH2011 [showdialog={false|true}] [numberOfThreads=number];

Compute the rSPR distance for two rooted binary trees on the same taxon set

compute distance method={hardwired|softwired|displayedTrees|tripartition|nestedLabels|pathMultiplicity} ;

Calculate distances between two trees or networks

compute DTL_reconciliation ; Calculate DTL reconciliation between two binary trees

Selection and Deselection:

select all ; Select all nodes and edges

select nodes={all|none|leaves|labeled}; Select nodes

select edges={all|none|short|long} [threshold=<number>];

Select all or none edges, or all edges

longer than or shorter than the given threshold

select previous ; Select all labeled nodes as in previous window

select nodes=labeled ; Select all labeled nodes

select nodes=leaves ; Select all leaves

select subnetwork ; Select subtree or subnetwork below node or edge

select inducedNetwork ; Select subtree or subnetwork induced by selected nodes

select lsaInducedNetwork ; Select subtree or subnetwork rooted at the LSA of the selected nodes

select subpart ; Select parts of tree that are reachable from any selected node without crossing any reticulate edges

select nodes=nonterminal ; Select all non-terminal nodes and egdes

select spanned ; Select all edges that connect any two selected nodes

select root ; Select root

select special ; Select all ’special’ edges

select invert ; Invert the current selection

select panels=all; Select all panels

select panels=invert; Invert the selection of all panels

select panels=none; Deselect all panels

deselect all ; Deselect all nodes and edges

deselect nodes ; Deselect all nodes

deselect edges ; Deselect all edges

list taxa=selected ; List all currently selected taxa

Searching:
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show finddialog={true|false} ; Show or hide find/replace dialog

find searchtext=text target={Nodes|Edges} [all=bool] [regex=bool] [wholeword=bool] [respectcase=bool] -

Find and select labels matching the given search text

replace searchtext=text replacetext=text [target={Nodes|Edges}] [all=bool] [regex=bool] [wholeword=bool] [respectcase=bool] ;

Find and replace labels matching the given search text

Collapsing and uncollapsing nodes:

collapse what={selected|complement} ; Collapse all selected nodes or their complement

collapse level=<integer> ; Collapse all nodes at the given level (distance from root)

uncollapse what={all|selected|subtree} ; Uncollapse all nodes, all selected nodes, or the whole subtree below each selected node

Visualization:

set grid=rows x cols ; Set the tree grid dimensions

set window [width=num][height=num][x=num][y=num] ;

Set size and location of main window

set layouter={Unoptimized|Algorithm2008|Algorithm2009|Algorithm2010|Algorithm2010Dist|AlgorithmLSA} ;

Chooses the way the network embedding is computed.

set font=name Set font by name

set autolayoutlabels={true|false} ; Set auto-layout of labels

set margin [left=num][right=num][top=num][bottom=num] ;

Set the margin around the tree

set approxthreshold=int ; Set minimum threshold for representing subtrees by approximate shapes

show edgelabels={true|false} ; Show or hide edge labels

show edgeweights={true|false} ; Use the edge weights as edge labels

show nodelabels={true|false} ; Show or hide node labels

show boarders={true|false} ; Show or hide borders

show scalebar={true|false} ; Show or hide scale bar

show scrollbars={true|false} ; Show or hide scroll bars

set edgeshape=value ; Set the shape of selected edges (possible values: angular straight curved)

set nodeshape=value ; Set the shape of selected nodes (possible values: rectangle oval none)

set radiallabels={true|false} ; Set radial layout of node labels

set sparselabels={true|false} ; Set sparse layout of node labels (in which labels that would overlap others are not shown)

set color=r g b ; Set the color of all selected nodes and edges

set fillcolor=r g b ; Set the fill color of selected nodes

set labelcolor=r g b ; Set the label color of all selected nodes and edges

set labelfillcolor=r g b ; Set the label fill color of selected nodes and edges

set edgewidth=num ; Set the line width of all selected edges

set nodesize=num ; Set the size of all selected nodes

Scaling:

contract direction=horizontal ; Contract horizontally

contract direction=vertical ; Contract vertically

expand direction=horizontal ; Expand horizontally

expand direction=vertical ; Expand vertically

zoom selection ; Zoom to current selection of nodes

zoom what=<{contract|expand|fit}> ; Fully contract, fully expand or zoom to fit the whole tree or network in the window

Controlling the magnifier:

set magnifier={true|false} ; Turn magnifier on or off

set magradius=<integer> ; Set magnifier radius

set magdisplacement=<float> ; Set magnifier displacement (power)

set magnifyallmode={true|false} ; Set the magnifier all mode

Adding images to nodes:

load imagedir=<directory-name> Load image files from named directory. Images are placed next to taxa of same name (recognized formats: GIF,

JPG, JPEG, BMP and PNG)

set imageheight=<integer> ; Set the height of the images associated with all selected nodes

set imagelayout=<value> ; Set the layout used for images (possible values: north south east west radial)

Special purpose:

update ; Update the trees

set dirty={true|false} ; Set the dirty status of a document

set vint={true|false} ; Set show version-in-window-title mode

set scalebar={true|false} ; Set show scalebar mode

set prop <name>=<value> ; Set the boolean value of a named property

tofront ; Bring window to front

Other:

set internalNodeLabelsAreEdgeLabels={false|true}

Do internal node label represent percent support (e.g. bootstrap values)?

orderNetworks [mode=<order|filter>] [noHybrid=<name,...>] [noRecent_hybrid=<name,...>] [hybrid=<name,...>] [recentHybrid=<name,...>]

Order or filter networks by whether specified taxa appear or do not appear below reticulate nodes

howtocite ; How to cite the program

website ; Go to the program website

version ; List version info

help [keyword] ; List this help or list help on given keyword

about ; List information about Dendroscope

close ; Close the window

quit ; Quit the program

Here is an example:

open file=’〈installation-dir〉/Dendroscope/examples/trees.new’;
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select taxa=AE007869;

set labelcolor=225 180 0; //to color the taxon AE007869 in the first tree

deselect nodes;

exportimage format=PDF file=’testExport.pdf’;

quit;

11 Command-Line Options

Dendroscope has the following command-line options:

Mode:

-g, --commandLineMode Run MEGAN in command-line mode. (Default value: false)

Commands:

-x, --execute [string] Command to execute at startup (do not use for multiple commands).

-c, --commandFile [string] File of commands to execute in command-line mode.

Configuration:

-E, --quitOnException Quit if exception thrown in command-line mode. (Default value: false)

-p, --propertiesFile [string] Alternate properties file. (Default value: /Users/huson/Library/Preferences/Dendroscope.def)

+w, --hideMessageWindow Hide message window. (Default value: false)

-V, --version Show version string. (Default value: false)

-S, --silentMode Silent mode. (Default value: false)

-d, --debug Debug mode. (Default value: false)

+s, --hideSplash Hide startup splash screen. (Default value: true)

Other:

-v, --verbose Be verbose. (Default value: false)

-h, --help Show program usage. (Default value: false)

Launching the program with option -g will make the program run in a command-line mode , first
excuting any command given with the -x option and then reading commands from the file specified
using the -c command. If no such file is given, additional commands are read from standard input.

Please note that windows will still open when in command-line mode, but should not be used
interactively. To prevent windows from opening, or to use the command-line mode on a server,
please use the linux virtual frame buffer command, as shown here:

xvfb-run --auto-servernum --server-num=1 Dendroscope +g

12 Examples

In this section we illustrate some of the features of Dendroscope.
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12.1 Basic tree view

Figure 1 shows the eight views possible with Dendroscope for the same phylogenic tree of mammal
species.

Figure 1: Illustration of the eight views possible with Dendroscope . Upper line: Rectangular Phylogram,
Rectangular Cladogram, Slanted Cladogram, Circular Phylogram. Lower line: Circular Cladogram, Internal Circular
Cladogram, Radial Phylogram, Radial Cladogram.

12.2 Additional tree view features

Figure 2 illustrates the action of the Magnifier on part of the NCBI taxonomy tree close to Homo
sapiens.

12.3 Editing trees

Figure 3 demonstrates some of the editing possibilities present in Dendroscope.
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Figure 2: Part of the NCBI taxonomy showing Homo sapiens and his relatives without and with the magnifier
turned on.

12.4 Constructing rooted phylogenetic networks

Figure 4 depicts two phylogenetic trees from the Poaceae dataset from the Grass Phylogeny Working
Group [6] and the 4 hybrid networks computed from these trees by the method presented in [1].

12.5 Tanglegram

Figure 5 shows a tanglegram between the first two networks in Figure 4(b).

13 Acknowledgements

This program includes software developed by the Apache Software Foundation (http://www.
apache.org/), namely the Batik library for generating image files. It also uses MR-
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Figure 3: All labels and tree substructures can be easily edited.

JAdapter , a Java package used to help construct user interfaces for the Apple Macintosh.
This program uses Daniel Huson’s unpublished jloda library, which is also used by SplitsTree4
(http://www.splitstree.org)[8, 10].
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